MySQL 4.x upgrade problems.

My provider recently upgraded to Debian Sarge and MySQL 4.1 which promptly broke my Wikipedia setup as below leading me to wild goose chase to http://dev.mysql.com/doc/mysql/en/old-client.html.


Client does not support authentication protocol requested
by server; consider upgrading MySQL client

The easy fix is to just change the mysql wikiuser password using the mysqladmin command as below:

mysqladmin -u <wiki-user> -p password <new-pass>

Shanker Balan

Shanker Balan is a devops and infrastructure freelancer with over 14 years of industry experience in large scale Internet systems. He is available for both short term and long term projects on contract. Please use the Contact Form for any enquiry.

More Posts - Website

Follow Me:
TwitterLinkedIn

Published by

Shanker Balan

Shanker Balan is a devops and infrastructure freelancer with over 14 years of industry experience in large scale Internet systems. He is available for both short term and long term projects on contract. Please use the Contact Form for any enquiry.